TIMS to PowerSchool Transportation Data Import

Extracting and Formatting TIMS Data

Creating the TIMS Extract(s) for PowerSchool
Extracting Student Transportation Data from TIMS
Formatting TIMS Transportation Data for Import into PowerSchool



TIMS Transportation Data Import for PowerSchool

Creating the TIMS Extract for PowerSchool — All Schools

1) In TIMS Reports, go to User Defined>All Students and Transportation

2) Highlight the “Standard All Students” report and Choose Copy

3) Name the copied report “TIMS Extract for PowerSchool — All Schools”

4) Open the Report and Edit the Output Fields to include only the following variables

a) Student District ID TIMS NT TIMS SQL
b) Trip Type Fields to include in query Selected
. . e tudent District ID
c) Stop Description ol danil HoTpe
i stol cription Stop Description
d) Time at Stop rzn't)rgﬁ'simep:t Stop Time at Slop
e) Route ID rtefrq Route ID rtefrg Route ID

5) Next, Edit the Report Filter and Sort Order so that only Route Riders with a PowerSchool ID are
Extracted and the file is sorted by Student District ID

Filters — | EditSoOrder | [

student District ID is not an empty field and
route Route ID is not an empty field and
student School is not an empty field




TIMS Transportation Data Import for PowerSchool
Creating the TIMS Extract for PowerSchool — All Schools

6) Next, Edit the Report Output Type so the TIMS Extract will be created as an Excel File
7) Modify the File Name and Output Path where the Extract will be generated

Worksheet

& Microsoft Excel Version 5 worksheet (XLS)
otus waorksneet Z.A (. extension

ASCII text file | In this example, the Extract will be generated as an Excel File
et at the root of the D:Drive with the name QMF_All_Schools

" Text file with comma separated fields
" Textfile with tab separated fields
" Textfile with blank separated fields

EICHETERND : \QMF ALL_SCHOOLY

Users could also create a “PowerSchool” folder where the
i TIMS Extract file will be generated. If so, users will need to
1 modify the Output Path accordingly.

| CNET D - | POVERSCHOOLY QMF ALL SCHOOLS|

This completes creation of the TIMS Extract for PowerSchool — All Schools

8) Copy this Report and Modify the Filter and Output Name so the Extract can be performed for
just a few Selected Schools.



TIMS Transportation Data Import for PowerSchool
Creating the TIMS Extract for PowerSchool — Choose School(s)

When importing TIMS Transportation Data into PowerSchool, LEAs have the option to import data for All Schools or for only a
Select Number of Schools. If an LEA only wants to update Transportation Data for one school or just a few schools, users will need
to create a second report called TIMS Extract for PowerSchool - Choose School(s)

1) Under User Defined>All Students and Transportation; Copy the report that was just created “TIMS Extract for
PowerSchool — All Schools” and name the copied report “TIMS Extract for PowerSchool — Choose School(s)

2) Edit the Report Filter so the TIMS Extract will only pull Transportation Data for Students with a certain School
Code

a) Change the filter “Student School is not an empty field” to

‘Student School is within a list — Ask Later”

STEP 2: Pick an Operator |

TIMS Extract for PowerSchool - Choose School(s)

student District ID is not an empty field and
route Route ID is not an empty field and
i student School matches {list of values}

" Between two values

@ |s within a list
€ 15 within a list - Begins with v Ask Later

b) After editing this filter, the system will ask which schools to include in the TIMS Extract
c) The Output File Name also needs edited each time the Choose School(s) extract is generated. Edit

the output file name to reflect the school(s) needed in the report.
These two examples would be for School 304 and Schools 304 and 316

File name: m

HICWETGERD - |\ QMF_SCHOOLS 304316




TIMS Transportation Data Import for PowerSchool
Extracting TIMS Data: Two Options — All Schools or Choose School(s)

A. TIMS Extract Report Filters

1. TIMS Extract for PowerSchool - All Schools

. District ID is Not Empty, Route ID is Not Empty, School is Not Empty
» This will compile ridership data for All Schools for students who have a
PowerSchool ID in TIMS and are fully assigned to a TIMS Route.

2. TIMS Extract for PowerSchool —-Choose School(s)

. District ID is Not Empty, Route ID is Not Empty, School is within a List (Ask Later)
» This allows the user to choose one or more schools to compile ridership data

from. Students must have a PowerSchool ID in TIMS and be fully assigned to a
TIMS Route.

TIMS Extract for PowerSchool - All Schools
TIMS Extract for PowerSchool - Choose School(s)




TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

The TIMS Extract will generate a Microsoft Excel File containing the necessary TIMS information
for import into PowerSchool.

Name A 3 C D 3
&) qmf_304_306_308 1 distid __triptype  stp desc dir time__ route id__
e e e 2 7000000104888 1 N PRINCE HENRY WAY & BIRNAM LN 739 AM 59
&) gmf_elem 3 7000000104888 2 N PRINCE HENRY WAY & BIRNAM LN 404PM 59
&) qmf_high 4 000000169858 1 BLUES CROSSING 754 AM 274
2] qmf_middle 5 1000000169858 2 BLUES CROSSING 430PM 74

There will be one line of data for each Student Trip in TIMS. So for each student who rides To
School and From School, there will be two lines of data, one for AM and one for PM.

Each line will contain the following:
» Student PowerSchool ID
* Trip Type (To/From School)
» Stop Description or Location
« Time at Stop
 TIMS Route ID or Bus Number



TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

In order for this file to import correctly into PowerSchool, you will need to make a few minor edits to
the spreadsheet.

1) First, you need to Rename Each Column Header to Match the Field Names in PowerSchool

 Column A = Student_ Number (must have underscore, no space)

« Column B = FromTo (no space or underscore)
* Column C = Description

* Column D = DepartureTime (no space or underscore)
 Column E = BusNumber (no space or underscore)

When finished editing the column labels, your spreadsheet should look like this.

A B C D E
1 Student_Number FromTo Description DepartureTime BusNumber
2 199043 To 314 SUNRISE AV 7:52 AM 13
3 199043 From 314 SUNRISE AV 4:20 PM 13
4 312474 To 254 OAK LEAF RD 8:06 AM 44
5 312474 From 254 OAK LEAF RD 4:23 PM 44
6 577301 To BREWER ST & N ELM ST 7:58 AM 108
7 577301 From BREWER ST & N ELM ST 3:46 PM 108
8 592336 To TIPTON DR & TABOR CT 8:08 AM 108
9 592336 From TIPTON DR & TABOR CT 3:56 PM 108
10 592471 To GREENVALE RD & N FAYETTEVILLE 7:50 AM 13
11 592471 From GREENVALE RD & N FAYETTEVILLE 4:19 PM 13
49 LEO2L02 Tao 2440 Ol DL CADRACD DDy Z-£0 ARA A4




TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

2) Next, you will need to remove the leading zeros from the Student PowerSchool Number. This is
accomplished by highlighting all of the PowerSchool IDs in Column A and converting from Text
format to Number format. After highlighting from Cell A2 to the end of Column A, move back to the
top of the spreadsheet and use this icon @ to convert to Number.

_ A B A
1 Student Numberg&zagalo Description 1 Student_Number
2 {000000104838 1 N PRINCE HENRY WAY, 2 104888
7 3 l'000000104888 A AL CPIA LA LALLM \AIAY 3 104888
4 l.000000169858 Number Stored as Text a 451 123222
5 l,000000169858 Convert to Number 6 215149
LA 1000000215149  —pr




TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

3) PowerSchool will only accept the words “To” or “From” in Column B, so you will need to perform
a search and replace on this data. The data from TIMS in Column B is the Student Trip Type, where

1 = “To School” Trip
* 2 ="From School” Trip

To edit this data, select Column B and then under the Home Tab, Choose Find & Select>Replace.
Replace the “1” with “To” and the “2” with “From”

TIMS Tip: LEAs with Complex Routing Operations may have additional Trip Types (3, 4, 5, 6, etc.)
for some students. If so, perform a Search and Replace on these additional Trip Types as well.

] = =® =
Description o @o@@ =
N PRINCE HENR Y VvVasy & BN =
N PRINCE HENR Y Vvasy & BiIRN ﬁl? }}

BlLUES CROSSING Z L

BLUES CROSSING Sort & |Find &

1706 CREST DR Filter = [Select =

1706 CREST DR ting 42 Find...

1706 CREST DR = Eeniace 5
1706 CREST DR - " e ="
CAROLINA PINES DR & PPINEWY v | E——
CAROLINAS PINES DR & PINNEWVY |R=DIGEEIC"|‘-HF
CAROLINA L AKES MHHP | Replace text in the document.
142 PMMIICHAEL LY e

Il
¢
30
.|
0

125 HEATHER LN CORmen s
DOGWVVOOD ST & SEYhNMOU R S
IROMNVVOOD RD & OA =T
IROMNWVVOOD RD & OAK ST Constants

BLUES CROSSING Data Validation
BlLUEFES CROSSING
25 FOX RUN RD L  Select Objects
245 FOX RUN RD S5 Selection Pane...
1284 L COORFPER RD L —
= o

ANANANSANSANANANSN SN S




TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

3) PowerSchool will only accept the words “To” or “From” in Column B, so you will need to do a
search and replace on this data. The data from TIMS in Column B is the Student Trip Type, where

 1="To School” Trip
* 2 ="From School” Trip

To edit this data, select Column B and then under the Home Tab, Choose Find & Select>Replace.
Replace the “1’s” with “To” and the “2’s” with “From.

Find and Replace [ 2] %]
g rec | A B C
Zﬁ:ﬁm }Ll il 1 Student Number FromTo Description

= ) 258290To  BLEVINS EXPRESS RD & US HWY 22
T e — | 258290 From  BLEVINS EXPRESS RD & US HWY 22
= 4 302633 From 417 WILL VANNOY RD
- 5 5 31484To 916 JOINESRD
Replacedll | Replace Frddl | [[EndNet | cose |




TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

Additional Edit Needed Prior to February 2016 PowerSchool Update:
Truncating the TIMS Stop Description to 30 Characters

The default design of the Student Transportation Screen in PowerSchool limits the Student Stop
Description to 30 characters or less. In TIMS, the Stop Description can contain up to 60
characters. Therefore, LEAs who wish to import TIMS Bus Stop Locations or Descriptions must
manually truncate TIMS data to a maximum 30 characters prior to importing TIMS Data into
PowerSchool.

Note: The February 2016 PowerSchool Update is scheduled extend the character length of the Stop Description Field to 60
characters, making this additional step obsolete after the update is completed.

Use the following steps to manually truncate the TIMS Stop Description to 30 Characters.
In the spreadsheet, insert an additional blank column after the Stop Description
Highlight the column containing the Stop Description

Under the Data Tab, Choose Text to Columns

Select Fixed Width and Next

Split the Column into two by inserting a break at the 30 Character mark

Click Finish to complete Text to Columns

Delete the additional column created and save the file as a CSV

Noahkhowh=



TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

Truncating the Stop Description Field to 30 Characters

Step 1: Insert a Blank Column after Stop Description

C D

stp_desc__ <fp_time_
314 SUNRISE AV 7:52 AM
314 SUNRISE AV 4:20 PM
254 OAK LEAF RD 8:06 AM
254 OAK LEAF RD 4:23 PM
BREWER ST & N ELM ST 7:58 AM
BREWER ST & N ELM ST 3:46 PM
[TIPTON DR & TABOR CT 8:08 AM
TIPTON DR & TABOR CT 3:56 PM
GREENVALE RD & N FAYETTEVILLE ST 7:50 AM
GREENVALE RD & N FAYETTEVILLE ST 4:19 PM

Step 2: Highlight the column containing Stop Description
Step 3: Under the Data Tab, Choose Text to Columns

Page Layout Formulas
> LE
= ] .
Existing Refresh
Connections All - -

F | stp_desc__

] D =
stp_desc___ <fFp_time_
314 SUNRISE AV 7:52 AM
314 SUNRISE AV 4:20 PM
254 OAK LEAF RD 8:06 AM
254 OAK LEAF RD 4:23 PM
BREWER ST & N ELM ST 7:58 AM
BREWER ST & N ELM ST 3:46 PM
TIPTON DR & TABOR CT 8:08 AM
TIPTON DR & TABOR CT 3:56 PM
GREENVALE RD & N FAYETTEVILLE ST 7:50 AM

GREENVALE RD & N FAYETTEVILLE ST 4:19 PM




TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

Truncating the Stop Description Field to 30 Characters

Step : Iect “Fixeidth” and then Next

Text to Columns Wizar

The Text Wizard has determined that your data is Delmited.
If this is correct, choose Next, or choose the data type that best desaribes your data.

Original data type
Choose the fie type that best desaribes your data:

F Fixed width - Fields are aligned in columns with spaces bemmtamﬁddl

Preview of selected data:

p_desc__
14 SUNRISE AV
B14 SUNRISE AV
BS54 OAK LIAF RD

AK LEAF RD

-FEEEE
S
g

Step 5: Split the Column into two by inserting a column break at the 30 Character Mark.
Hint: Click on the number 30 to set the maximum character length for the Stop Description field, then Finish to

complete Text to Columns

Convert Text to Columns Wizard - Step 2 of
This screen lets you set field widths (column breaks).

Lines with arrows signify a column break.

To CREATE & break line, dick at the desired position.

To DELETE a break line, double click an the fine.

To MOVE a break ine, cick and drag it.

2
3
2

'n.




TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

Truncating the Stop Description Field to 30 Character

Step 6: Click Finish to Complete Text to Columns
* Column C will contain the first 30 Characters of the TIMS Stop Description

» Column D will contain characters 31 to 60 of the TIMS Stop Description
Note: Stop Descriptions that are more than 30 Characters typically contain additional data (ex: Boys and Girls Club) and/or are

Stops located at a corner. The majority of TIMS Stop Descriptions are generally less than 30 Characters.

C D E
stp_desc__ stop_time_
621 FRANKS ST BOY'S/GIRL'S CLuB 2:45 PM
621 FRANKS ST BOY'S/GIRL'S CLUB 245 PM
621 FRANKS ST BOY'S/GIRL'S CLUB 2:45PM
621 FRANKS ST BOY'S/GIRL'S CLUB 2:45PM
VALLEY DALE LA & MAPLE RIDGE R D 7:40 AM
VALLEY DALE LA & MAPLE RIDGE R D 4:06 PM
OLD CEDAR FALLS RD & STONE HAV EN DR 7:56 AM
OLD CEDAR FALLS RD & STONE HAV ENDR 3:57TPM
MCCRANFORD RD & CEDAR GROVE DR EX 7:09 AM
MCCRANFORD RD & CEDAR GROVE DR EX 3:03PM
N MCCRARY ST & LORD RANDOLPH C IR 7:15 AM
N MCCRARY ST & LORD RANDOLPH C IR 7:15 AM
N MCCRARY ST & LORD RANDOLPH C IR 2:44 PM
N MCCRARY ST & LORD RANDOLPH C IR 7:15 AM
N MCCRARY ST & LORD RANDOLPH C IR 2:44 PM
N MCCRARY ST & LORD RANDOLPH C IR 7:15 AM
N MCCRARY ST & LORD RANDOLPH C IR 2:44 PM
DUNLAP ST & MARTIN LUTHER KING JDR 7:09 AM
DUNLAP ST & MARTIN LUTHER KING JDR 2:31PM

Step 7. Delete the newly created Column D and Save the File as a CSV



TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

Truncating the Stop Description Field to 30 Character

After completing all of the necessary edits to the TIMS Extract, the spreadsheet should look similar
to the image below.

A B C D) =
1 Student_Number FromTo Description DepartureTime BusNumber
2 199043 To 314 SUNRISE AV 7:52 AM 13
3 199043 From 314 SUNRISE AV 4:20 PM 13
4 312474 To 254 OAK LEAF RD 8:06 AM 44
5 312474 From 254 OAK LEAF RD 4:23 PM 44
6 577301 To BREWER ST & N ELM ST 7:58 AM 108
7 577301 From BREWER ST & N ELM ST 3:46 PM 108
8 592336 To TIPTON DR & TABOR CT 8:08 AM 108
9 592336 From  TIPTON DR & TABOR CT 3:56 PM 108
10 592471 To GREENVALE RD & N FAYETTEVILLE 7:50 AM 13
11 592471 From GREENVALE RD & N FAYETTEVILLE 4:19 PM 13
49 LO2END Ta N440 NI D CADMED DN Z-E0 ARA AA

The final step is to save the edited TIMS Extract as a CSV file.

See Next Slide.



TIMS Transportation Data Import for PowerSchool
Extracting & Formatting TIMS Data

4) The final step before importing into PowerSchool is to save the edited file as a CSV.

Choose File>Save As and change the “Save as Type” to CSV (Comma Delimited)

Home Inss

H Save
[ B save As }

7 Open

i Close

_ File name: qmf_all_schools

Recent Save as type: | CSV (Comma delimited)

When completed, you will have a CSV (Comma Separated Values) File ready for Import.

Name . Type

&) qmf_304_306_308 Microsoft Excel 97-2003 Worksheet

@ qmf_all_schools Microsoft Excel Comma Separated Values File
&) qmf_all_schools Microsoft Excel 97-2003 Worksheet

L’;_‘_l] gmf_elem Microsoft Excel 97-2003 Worksheet

& gmf_high Microsoft Excel 97-2003 Worksheet

@J gmf_middle Microsoft Excel 97-2003 Worksheet




TIMS Transportation Data Import for PowerSchool

Summary of Steps to Complete the Extraction and Formatting of the
TIMS to PowerSchool Bus Stop Import File

1) Run the Bus Stop Extract Report as needed for...
a) All Schools
b) One School
c) One or More Schools
2) Rename the Column Headers to Match the PowerSchool Field Names

a) Column A = Student_ Number (must have underscore, no space)
b) Column B = FromTo (no space or underscore)

c) Column C = Description

d) Column D = DepartureTime (no space or underscore)

e) Column E = BusNumber (no space or underscore)

3) Remove the Leading Zeros from the PowerSchool ID
a) Highlight all IDs and Convert to Number Format
4) Search and Replace Trip Types in Column B
a) 1= "To School” Trip
b) 2 ="From School” Trip
4a) Truncate Stop Description to 30 Characters (prior to February 2016 Update to PowerSchool)
5) Save the Newly Edited File as a CSV (Comma Delimited )
a) File>Save As> CSV (Comma Delimited)



